[Samba] IOS connections to Samba 4 worked for years, now authentication fails

Rowland Penny rpenny at samba.org
Sat Sep 29 08:10:55 UTC 2018

On Fri, 28 Sep 2018 21:38:07 -0700
Deft Developer via samba <samba at lists.samba.org> wrote:

> We have samba 4.8 and 4.9 servers that are Active Directory members.
> Windows and other samba clients can access the shares, and for years,
> iOS devices worked fine with Samba 4. But a few months ago, Apple IOS
> 10 and 11 devices started failing to authenticate. The problem is
> common to several iOS apps, FileBrowser, SMBManager, and some others
> all fail. The App vendors are stonewalling us, and giving stupid
> advice like restarting the devices.
> The logs on the Samba servers say FAILED with error
> NT_STATUS_LOGON_FAILURE, regardless of what type of
> username+password, with or without the domain name.
> The problem is only between iOS and Samba. These same iOS clients can
> connect to Windows 7 and Windows server 2008 shares, and Windows and
> Samba clients can access the shares as expected.
> What happened, and is there a way around this issue?

We are going to need more info here, what is in smb.conf for a start.
When did the problem start ?
Was it after an update of Samba ?
If so, what version did you upgrade from ?


More information about the samba mailing list