[Samba] IOS connections to Samba 4 worked for years, now authentication fails

Deft Developer dev at hymes.name
Sat Sep 29 04:38:07 UTC 2018

We have samba 4.8 and 4.9 servers that are Active Directory members. Windows
and other samba clients can access the shares, and for years, iOS devices
worked fine with Samba 4. But a few months ago, Apple IOS 10 and 11 devices
started failing to authenticate. The problem is common to several iOS apps,
FileBrowser, SMBManager, and some others all fail. The App vendors are
stonewalling us, and giving stupid advice like restarting the devices.


The logs on the Samba servers say FAILED with error NT_STATUS_LOGON_FAILURE,
regardless of what type of username+password, with or without the domain


The problem is only between iOS and Samba. These same iOS clients can
connect to Windows 7 and Windows server 2008 shares, and Windows and Samba
clients can access the shares as expected.


What happened, and is there a way around this issue?

More information about the samba mailing list