[Samba] 4.8.5 + TimeMachine = Disk identity changed on every connect, cannot backup

John Keates john at keates.nl
Mon Sep 17 00:31:58 UTC 2018

I configured Samba 4.8.5 on Debian with vfs_fruit as a TimeMachine destination and while it detects it and does the initial backup to some extent (300GB out of 600GB), TimeMachine then fails with a message about the disk identity having changed.
Options are “don’t backup” and “backup anyway”. When using “backup anyway”, the backup creates a secondary sparse image and starts from scratch, and won’t even touch the existing sparse image.

While I understand that this is specific to macOS, TimeMachine and vfs_fruit combined, the Samba mailing list is the only one I could find regarding Samba and vfs_fruit.

Is there anyone experiencing this issue, and is there a way to get more information from either macOS or Samba to find out why TimeMachine thinks the disk identity keeps changing?

Underlying FS for the share is ZFS, but I tried it with EXT4 and that gives the same result.


More information about the samba mailing list