[Samba] Samba4 on Ubuntu 18.04

Rowland Penny rpenny at samba.org
Tue May 8 14:52:11 UTC 2018

On Tue, 8 May 2018 16:25:16 +0200
Micha Ballmann via samba <samba at lists.samba.org> wrote:

> I installed two samba ad in replication. One fileserver (domain
> member) and printserver (domain member). I built a CTDB cluster with
> it. All are running on Ubuntu 18.04 LTS!
> On the AD Server i got a problem with the internal DNS from samba 
> because systemd-resolver thought it is the DNS boss now. I disabled 
> systemd-resolve (systemctl disable systemd-resolved.service) and
> mange the resolve.conf manually.

Yes, that was one of the problems I ran into 

> Some tips before you install samba:
> - If not needed uninstall "cloud init" (some trouble with setting 
> hostname and  /etc/hosts file):
> # 
> https://makandracards.com/operations/42688-how-to-remove-cloud-init-from-ubuntu
> - If youre using ntp, disable systemd's timesyncd service (ntp
> service will now start after reboot)

Didn't have that problem, it just worked for me.

> # timedatectl set-ntp off
> Please notice, in Ubuntu 18.04 stable not in BETA version, now a 
> "swap.img" is mounted in "/" . No swap partition anymore!

AAAGGGHH, you are correct, except I have a swapfile, what idiot thought
that up ???

> In my opinion samba is ready for Ubuntu 18.04.

Yes, but is Ubuntu 18.04 ready for Samba ? :-)

More information about the samba mailing list