[Samba] Errors "Domain password server not available" and "SPNEGO login failed: The request is not supported"

Rowland Penny rpenny at samba.org
Mon Jul 9 09:15:43 UTC 2018

On Mon, 9 Jul 2018 10:55:11 +0200
M.Eng. René Schwarz via samba <samba at lists.samba.org> wrote:

> Hi,
> I am running an Ubuntu 14.04 server with Samba
> 2:4.3.11+dfsg-0ubuntu0.14.04.14, which just provides storage services
> to the network. It is configured to use an existing Active Directory
> infrastructure based on Windows servers.
> Since some weeks I am experiencing issues with accessing the network
> shares served by Samba (no matter which client/operating system).
> Connection/mounting attempts ultimately fail most of the time. I am
> seeing errors like "SPNEGO login failed: The request is not
> supported." and "domain_client_validate: Domain password server not
> available." in the logs. But sometimes, without changes on the server
> side, accessing the shares works fine. An excerpt of the full log is
> attached below.
> I tried many hours already to solve the problem by modifying the Samba
> configuration without success, however, the original configuration
> worked fine for years.
> I have no clue how this issue can be solved and would appreciate any
> support.
> Thank you in advance and kind regards,
> René

At first glance it looks like your Ubuntu server is trying to use
NTLMv1 against something that no longer uses it.

Can you post your smb.conf and tell us what your windows servers are ?


More information about the samba mailing list