[Samba] Centos 7 AD domain provision won't create named.conf

Kacper Wirski kacper.wirski at gmail.com
Tue Jul 3 05:59:24 UTC 2018


I don't know about provisioning, but when joining as DC to existing 
domain samba 4.8.3 with dns backend BIND9_DLZ all the bind related files 
are created inside "samba/bind-dns" directory inside /usr/local/samba, 
instead of the previous samba/private. I think there is new option to 
specify directory, were all bind related files are to be kept, and 
samba/bind-dns is the default value.

Also, as a sidenote I noticed myself wrong behaviour of --dns-backend 
option during join of DC to existing domain with samba 4.8.3:

If i run:

samba-tool domain join my.domain DC --dns-backend=BIND9_DLZ 

in my samba directory there will be "bind-dns" directory created, with 
"named.conf" inside, but file permissions are wrong (root:root instead 
of root:named), and named.keytab is created inside samba/private/.

Once i run after join:

samba_dnsupgrade --dns-backend=BIND9_DLZ

All the files are created as they should (/samba/bind-dns/ has correct 
permissions and named.keytab is created/moved to this directory as well).

This behaviour is repetitive, on centos 7.5 at least.


W dniu 03.07.2018 o 01:45, Alberto Moreno via samba pisze:
> Hi guys.
> I'm preparing my migration from samab NT4 style to AD.
> I had follow some papers about, exist 1 step that I still don't if is right
> or don't.
> A lot of site show that once we run the command:
> samba-tool domain provision ...
> using BIND9_DLZ
> This step will create a named.conf inside ./private/named.conf
> I have run a lot of times the command, but won't see this file.
> Is normal?
> I have download the latest samba 4.8.3, running centos 7 update fresh
> installation.
> Thanks.

More information about the samba mailing list