[Samba] Samba 4.6.7 AD, Netapp CDOT 9.2 and missing "Domain Users" membership

Giuseppe Ravasio giuseppe_ravasio at ch.modiano.com
Wed Oct 25 10:54:18 UTC 2017

On 10/24/2017 12:52 PM, Rowland Penny via samba wrote:
> If they support a windows DC, then it should also work with a Samba DC,
> just ask them how to they expect the netapp to be set up to connect to
> a windows DC, they should at least be able to do this.

The Netapp CIFS is set up exacltly as the doc says and, as I said
before, it works fine except for the Domain User membership.
There is plenty of documentation on Netapp side on how to setup the
filer and we followed the docs.

> I repeat, if it works with a windows DC, it should work with a Samba DC.

As I said before it works as expected with a Windows DC.
We double checked before writing to you setting up a new AD with Windows
2016 DC and I can confirm that with Windows the group membership works
as expected.
We also tried to redeploy the Samba Domain with the latest 4.7.0 and the
result is still the same.

> Have you tried asking them if the netapp uses Samba ? and if so, what
> version.

As I said before Netapp seems not to be using Samba but their own
Also, if it where so, I think that GPL license would oblige them to
pubblish their changes that would be substantial.
Otherwise, if they had stolen some Samba code (which I doubt given the
fact that we are talking about the second player in enterprise storage
market and one of Fortune 500 company) they shurely wouldn't tell me!

In the KB article number 000001134 they officialy say that
"NetApp does not perform full interoperability testing between the Samba
client and Data ONTAP. Should an issue arise, using the resources
provided by Samba (documentation, forums, etc.) is recommended as a
first step. NetApp support personnel will assist on a best effort basis.
NetApp does not currently support Samba domain controllers in any capacity."

> What actual netapp is this ?

BTW If you are interested in having some debug logs or test something,
we have both Samba 4.7 and Windows 2016 ready for testing with the
Netapp system


More information about the samba mailing list