[Samba] Problem with AD DC

Rowland Penny rpenny at samba.org
Sun Oct 15 13:03:05 UTC 2017

On Sun, 15 Oct 2017 14:11:52 +0300
Ronald Vyhmeister via samba <samba at lists.samba.org> wrote:

> Thank you for your reply. This was not a random link I followed. I
> have reviewed the Samba documentation at
> https://wiki.samba.org/index.php/Setting_up_Samba_as_an_Active_Directory_Domain_Controller,
> and all the testing that is listed there results in correct and
> expected answers... I had already noted the /etc/hosts situation,
> which interestingly does not change the answers I get in testing
> (I've tried it both ways, just in case).
> The network manager is not running. The server is running Ubuntu
> 16.04 LTS without a GUI.
> As I noted I can also connect to the server with the \\servername and
> entering "administrator" as the username and then the password. No
> errors there.
> What I'm trying now to do is to join a Windows 10 box to the AD domain
> served by SAMBA, and when I do that is when I get the error that the
> username or password is incorrect.

Who are you using to do the join ?
Have you tried with Administrator and the password you used to
provision the DC ?
Is the win 10 machine using the DC as its dns server ?

> Are there any restrictions on password contents? I am using a
> generated password that contains plenty of special characters. I am
> not aware of any (and would hope they don't exist).

The password restrictions for a Samba domain is the same as a windows
domain, see here:



More information about the samba mailing list