[Samba] Samba Active Directory Domain Controller

Rowland Penny rpenny at samba.org
Tue May 9 14:55:37 UTC 2017

On Tue, 9 May 2017 15:14:16 +0100
martini5468--- via samba <samba at lists.samba.org> wrote:

> Hash: SHA512
> On 08/05/17 19:11, lingpanda101 via samba wrote:
> >>> I believe Rowland is speaking specifically to CentOS 7.3 and not
> >>> Ubuntu. CentOS requires network config changes in
> >>>
> >>> /etc/sysconfig/network-scripts/ifcfg-"Your Interface"
> >>>
> >>> I can't recall where in CentOS to make changes to resolv.conf.
> >>>
> >> What I was trying to point out was that I couldn't change anything
> >> in /etc on Centos 7.3, I wasn't allowed to. I couldn't change
> >> something on my own computer because somebody, somewhere has
> >> decided I shouldn't. I can guess what it is, but without in depth
> >> investigation, I cannot point the finger at anything.
> >>
> >> All I wanted to do was change the nameserver, but, as I said, I
> >> wasn't allowed to.
> >>
> >> I would also like to point out I know where to put the settings,
> >> if I am changing them permanently, even on a raspberry pi ;-)
> >>
> >> Rowland
> >>  
> > Where do you make the changes on CentOS to update resolv.conf? OP
> > should verify his isn't being overwritten. Thanks.
> I may be a bit too late jumping on this thread but here are a few
> pointers:
> 1. /etc/resolve.conf is automagically generated/updated by
> NetworkManager
> 2. any DNS entries in ifcfg files in /etc/sysconfig/network-scripts
> get put in /etc/resolve.conf by NetworkManager
> 3. systemd can be set to mount the system filesystems read-only. This
> can be checked in /etc/sysconfig/readonly-root. I tried to look for
> more info on read-only rootfs but found only bug reports ;). I have
> also heard talk that people have found their /etc as read-only after
> a CentOS 7 update - personally I have not experienced it.
> While tempting to just disable NetworkManager and configure your
> network scripts and resolve.conf any which way you like I ran into a
> problem where after the latest systemd update the boot time unit
> ordering is broken and any services trying to bind to an IP:PORT
> combo will fail[1][2]. E.g. having SSHD configured with ListenAddress
> XXX.XXX.XXX.XXX:22 will fail to start as systemd will try to bring up
> the service before the network-online target.
> The fix is to either drop-in a systemd unit override or to add a
> target dependency. According to readhat fix is on the way.
> [1] - https://bugzilla.redhat.com/show_bug.cgi?id=1438749
> [2] - https://bugs.centos.org/view.php?id=13146

I knew it, just what has an 'init' system got to do with mounting a
filesystem read only ??

I do not get any of these problems on the distro I use, it is MY
computer and I will set it up how I like, not as somebody has decided I


More information about the samba mailing list