[Samba] wbinfo -i returns the same id for all users, authentication doesn't seem to go through winbind at all

Emmanuel Florac eflorac at intellique.com
Tue Feb 28 18:26:39 UTC 2017

Le Mon, 20 Feb 2017 14:01:08 +0000
Rowland Penny via samba <samba at lists.samba.org> écrivait:

> On Mon, 20 Feb 2017 14:44:36 +0100
> Emmanuel Florac <eflorac at intellique.com> wrote:
> > Le Sat, 18 Feb 2017 20:17:12 +0000
> > Rowland Penny via samba <samba at lists.samba.org> écrivait:
> >   
> > > Only change I made before installing Samba, was to comment the
> > > '' line in /etc/hosts  
> > 
> > Tried again with your smb.conf and minimal changes, and it gets
> > worse: 
> OK, I set up Debian Jessie in a VM and then installed and configured
> Samba and it worked, this all took just about an hour.
> I suggest you check your settings against the ones I posted.

Hi Rowland, sorry to be back again.

I've set up a new test Win2012R2 AD server from scratch.
I've set up a Debian VM from scratch.
I've installed exactly the settings you sent (except for the AD name,
to reproduce the production configuration).

It doesn't work. Exactly the same problem. I can connect to the share
as Administrator because the users.map file maps Administrator to local
root (files created by Adminsitrator are owned by root) but *no other
user account* works unless I declare the share public, so that all
accounts are mapped to nobody.

"getent passwd testuser" returns nothing (return code is 2).

root at debadclient1:~# wbinfo -i bidon
bidon:*:11106:10513:bidon bidon:/home/TESTAD/bidon:/bin/bash
root at debadclient1:~# getent passwd bidon
root at debadclient1:~# echo $?

I'm getting desperate. 

I tried using a Debian 9/ samba 4.5.4. Exactly the same. At least the
behaviour is consistent...

Emmanuel Florac     |   Direction technique
                    |   Intellique
                    |	<eflorac at intellique.com>
                    |   +33 1 78 94 84 02
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 181 bytes
Desc: Signature digitale OpenPGP
URL: <http://lists.samba.org/pipermail/samba/attachments/20170228/2c5f3588/attachment.sig>

More information about the samba mailing list