[Samba] Fw: Re: Made a join with a netbios name, which already existed, now replication errors

Rowland Penny rpenny at samba.org
Wed Aug 2 07:18:07 UTC 2017

On Wed, 2 Aug 2017 08:50:38 +0200
gizmo via samba <samba at lists.samba.org> wrote:

> > Cleaned the DNS manually with the DNS application, but still I
> > can't join. Same error.
> I thought it was the same error, but now I saw there is a small
> difference. It seems like a deleted object causes the problem.
> With "ldbsearch --cross-ncs --show-deleted .." I can see now that
> entry for "samba3" (beside all other demoted servers), which appears
> in the error message.
> Can I delete that already deleted object with ldbdel just like a
> "normal" object ?
> ...
> Unxpectedly got mismatching RDN values when checking RDN against name
> of CN=NTDS
> Settings,CN=SAMBA3\0ADEL:e4ee9112-7457-47e9-a603-13a1c762cecf,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=domain,DC=university,DC=deFailed

No you cannot delete something that is already deleted, but then
deleted objects should be ignored and I think this is fixed in later

Does your Samba version have 'samba-tool domain tombstones expunge' ?
if it does, you can set the '--tombstone-lifetime' to 1 day and then
wait, all the 'OADEL' objects should disappear.


More information about the samba mailing list