[Samba] Domain DFS on new share

Mueller mueller at tropenklinik.de
Fri Apr 21 05:46:18 UTC 2017

Since  past the beta-times of samba 4  (and it worked in former times!!) it never worked like this: \\yourdomain\share or \\yourdomain \dfs-share.
The only thing working along witch your domain is: \\yourdomain\netlogon.

I had another thread open on this case some times ago.


EDV Daniel Müller

Leitung EDV
Tropenklinik Paul-Lechler-Krankenhaus
Paul-Lechler-Str. 24
72076 Tübingen 
Tel.: 07071/206-463, Fax: 07071/206-499
 Email: mueller at tropenklinik.de

-----Ursprüngliche Nachricht-----
Von: Jeremy Allison via samba [mailto:samba at lists.samba.org] 
Gesendet: Freitag, 21. April 2017 01:27
An: Jonathan Hunter <jmhunter1 at gmail.com>
Cc: samba <samba at lists.samba.org>
Betreff: Re: [Samba] Domain DFS on new share

On Fri, Apr 21, 2017 at 12:09:25AM +0100, Jonathan Hunter via samba wrote:
> Hi,
> I am trying to configure domain DFS (I think that's the correct term) 
> as below, using the guide on the wiki:
> https://wiki.samba.org/index.php/Distributed_File_System_(DFS)#Configu
> re_domain-based_DFS_in_Samba
> I am aware that the wiki says that this doesn't quite work... however 
> it feels to me that it's very close, nearly working, and I might be 
> able to get it going (hopefully?!) by means of a simple fix.. I can 
> dream, can't I?
> My goal is not to enable DFS-R (that's a whole other conversation - 
> and I use lsyncd for sysvol etc. at the moment, anyway) but rather to 
> simply use the redirection features so that (for example) 
> \\mydomain\dfs\publishedshare goes to \\myserver\realshare.
> My setup is as follows.
> On each of my four DCs, I have added the following to smb.conf:
> [dfs]
>         path = /usr/local/samba/dfsroot
>         msdfs root = Yes
> And in /usr/local/samba/dfsroot, again on all four DCs, I have a symlink:
> lrwxrwxrwx  1 root root   38 Apr 15 01:14 test ->
> msdfs:testserver.mydomain.org.uk\test
> The DCs already have the following (confirmed using testparm) :
> [global]
>         vfs objects = dfs_samba4 acl_xattr
> This new 'dfs' share works fine from my test Windows 7 and Windows 10 
> clients, if I access it via \\dc1\dfs, \\dc1\dfs\test, \\dc2\dfs\test, 
> \\dc3\dfs and so on.
> However, if I access the very same share via \\mydomain\dfs or 
> \\mydomain\dfs\test instead, then it fails with the following error:
> Windows cannot access \\mydomain\dfs. Error code 0x80070035 The 
> network path was not found.

Wireshark trace needed I think.

To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list