[Samba] backup_samba4 script failing

Bob of Donelson Trophy bob at donelsontrophy.net
Thu Nov 24 12:51:19 UTC 2016

On 2016-11-23 07:17, Bob of Donelson Trophy via samba wrote:

> On 2016-11-23 06:55, Rowland Penny via samba wrote:
> On Wed, 23 Nov 2016 13:47:37 +0100
> "L.P.H. van Belle via samba" <samba at lists.samba.org> wrote:
> Hi Bob, 
> Ah, now I see the the core of this problem. 
> This is the main problem. 
> You smbd -b output 
> Paths:
> SBINDIR: /usr/local/samba/sbin
> BINDIR: /usr/local/samba/bin
> CONFIGFILE: /usr/local/samba/etc/smb.conf             <<<<<<<<<< 
> LOGFILEBASE: /usr/local/samba/var
> LMHOSTSFILE: /usr/local/samba/etc/lmhosts
> LIBDIR: /usr/local/samba/lib
> MODULESDIR: /usr/local/samba/lib
> LOCKDIR: /usr/local/samba/var/lock
> And below in the email your telling that you config is in /etc/samba 
> Due to this mismatch, the script is failing. 
> I suppose the question is, does Samba know that smb.conf isn't where it
> thinks it is ?
> Are the Samba binaries being started with the -s option ?
> Rowland

I need to look into this. I could be wrong but I thought I had setup a
symlink between /etc/samba/smb.conf to /usr/local/samba/etc/smb.conf. 

I will review my notes to confirm what I did. 

I know that smb.conf IS located at /usr/local/samba/etc/ but, I also
know that I can access it via /etc/samba/smb.conf to make adjustments. 

Hum-m-m-m . . . 


Bob Wooden of Donelson Trophy 

Yes, during installation I ran "ln -s /usr/local/samba/etc /etc/samba"
to create a symlink to /usr/local/samba/etc/ and simplify smb.conf

When I run: 

root at dtdc03:/usr/sbin# ls -alh /etc/ | grep "samba/etc"
lrwxrwxrwx   1 root root     20 Oct 19 18:33 samba ->

Hope this helps. 


Bob Wooden of Donelson Trophy

More information about the samba mailing list