[Samba] Problem since upgrade to 4.5.1

John Gardeniers jgardeniers at objectmastery.com
Sun Nov 20 22:29:54 UTC 2016

Hi Mathias,

No Terminal Server is involved. This problem is affecting Windows 
machines trying to RDP to some other Windows machines. I've since 
learned that it's only a problem with a few of the target machines. 
Everything worked perfectly with Samba 4.4 and nothing else has changed.


On 19/11/16 03:32, mathias dufresne via samba wrote:
> Just a though as I was passing in the neighbourhood:
> does your Terminal Server have related SPN (ServicePrincipalName) created
> on computer objects?
> servicePrincipalName: HOST/W7AD-02
> servicePrincipalName: HOST/W7AD-02.ad.domain.tld
> servicePrincipalName: TERMSRV/W7AD-02.ad.domain.tld
> servicePrincipalName: TERMSRV/W7AD-02
> HOST/<hostname> should exist on all computers, that's just to be thorough.
> TERMSRV/<hostname> should exist on Windows you want to access through RDP
> (if my little understanding regarding SPN is correct)
> 2016-11-18 10:20 GMT+01:00 Alex Crow via samba <samba at lists.samba.org>:
>> On 17/11/16 21:48, John Gardeniers via samba wrote:
>>> Since upgrading our DCs to Sernet Samba v4.5.1 we are experiencing
>>> problems using Remote Desktop from Windows boxes. The rather useless and
>>> completely misleading error message states:
>>> "The connection cannot be completed because the remote computer that was
>>> reached is not the one you specified. This could be caused by an outdated
>>> entry in the DNS cache. Try using the IP address of the computer instead."
>>> We are able to RDP using the IP address from a Windows machine. We are
>>> also able to RDP by either name or address from a Linux machine. It's only
>>> when we try to connect by name from a Windows machine that we have this
>>> problem. It all worked perfectly fine prior to the Samba upgrade.
>>> It most certainly is not a DNS issue but just to be ultra sure the caches
>>> on both the client and destination boxes were flushed, We also rebooted
>>> both machines.
>>> The clocks were also checked against those on the DCs, with a maximum
>>> discrepancy of one second. The time on the two DCs matched to within 0.002
>>> seconds.
>>> Anyone have any theories about this? Or a solution?
>>> regards,
>>> John
>> Hi John,
>> I've just tested on our newest test domain and I could not reproduce this
>> connecting to our single Server 2008 R2 Terminal Server from Windows 7.
>> I presume you can resolve the names OK from your Windows client machine?
>> Cheers,
>> Alex
>> --
>> This message is intended only for the addressee and may contain
>> confidential information. Unless you are that person, you may not
>> disclose its contents or use it in any way and are requested to delete
>> the message along with any attachments and notify us immediately.
>> This email is not intended to, nor should it be taken to, constitute
>> advice.
>> The information provided is correct to our knowledge & belief and must not
>> be used as a substitute for obtaining tax, regulatory, investment, legal or
>> any other appropriate advice.
>> "Transact" is operated by Integrated Financial Arrangements Ltd.
>> 29 Clement's Lane, London EC4N 7AE. Tel: (020) 7608 4900 Fax: (020) 7608
>> 5300.
>> (Registered office: as above; Registered in England and Wales under
>> number: 3727592). Authorised and regulated by the Financial Conduct
>> Authority (entered on the Financial Services Register; no. 190856).
>> --
>> To unsubscribe from this list go to the following URL and read the
>> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list