[Samba] After reboot, permission denied

Dale Schroeder dale at BriannasSaladDressing.com
Tue Jun 28 21:10:40 UTC 2016

On 06/28/2016 11:37 AM, John Oliver wrote:
> I've had samba running under centOS 6 for quite some time now.  Last
> Friday, I applied updates and rebooted.  Ever since, I cannot access my
> samba shares :-(  This has worked through updates and reboots
> previously.
> My Linux servers won't run the mount command that's worked for months,
> they respond with "mount error(22): Invalid argument"  I set the
> loglevel to 5, and get a whole lot of jibber-jabber, but I do see
> complaints about NT_STATUS_WRONG_PASSWORD  I reset the samba user's
> password, and reset it to 'test', but always get the same results.
> My Macs will mount the share just fine, but any attempt to write files
> fails with permission denied.  Nothing shows up in the logs.
> My smb.conf looks exactly the same.  Tailing through samba and audit
> logs isn't telling me anything useful.  What else can I do to
> troubleshoot?

By your description, I'm guessing that you have upgraded to a version 
with the badlock patches.  CIFS mounts are broken; NT4 domains are 
broken; along with some other odds and ends.

To be certain, you should provide the Samba version and your smb.conf to 
the list.  Someone may be able to help you.

If you like, you can read the release notes here: 


More information about the samba mailing list