[Samba] Cannot write to home directory, but I can write to subfolder

L.P.H. van Belle belle at bazuin.nl
Thu Jan 21 10:45:20 UTC 2016

O..k.... well done.  :-)  but risky but he it worked.. one reason why im using debian, easy upgrading.  :-)  


Its a strang bug in 3.6.6 which i havent identified and since this samba is so old, im just restarting for now. 

2 servers to go and im out of 3.6...  finaly... 








Van: Nico De Ranter [mailto:nico.deranter at esaturnus.com] 
Verzonden: donderdag 21 januari 2016 11:36
Aan: L.P.H. van Belle
CC: samba at lists.samba.org
Onderwerp: Re: [Samba] Cannot write to home directory, but I can write to subfolder



Upgraded my Debian Wheezy server to Samba 4.1.17 via wheezy-backports.  The users hardly noticed a thing and now everything works. I'm impressed.

In case you need to do anything similar:

   echo "deb http://http.debian.net/debian wheezy-backports main" > /etc/apt/sources.list.d/wheezy-backports.list

   apt-get update

   apt-get -t wheezy-backports install samba
   /etc/init.d/samba restart        (not sure this step is really necessary as the upgrade probably already does that)




On Thu, Jan 21, 2016 at 11:20 AM, Nico De Ranter <nico.deranter at esaturnus.com> wrote:


I tried the following:

* rebooted both Samba DC's   -- no change

* restarted samba on storage server -- no change

* remove client pc from domain, tried accessing the folder from non-domain pc -- no change

* created a temporary server (running samba 4.x) to serve the same homedirectores -- no problem at all

So that narrows the problem down to something on the storage server.  I'll try readding the server to the domain. Hopefully nobody will notice (most of my users are linux based anyway except for sales and management)





On Thu, Jan 21, 2016 at 10:59 AM, Nico De Ranter <nico.deranter at esaturnus.com> wrote:

Hi Louis,

I tried restarting samba on the server already.  I also tried rebooting the client pc a number of times.  The folders are mounted via GPO's.  I assume rebooting the pc should have the same effect as remounting the shares?

I also had a look at the permissions from Windows.  When I look at the permissions of the new folder I managed to create I see there is a strange user with only an SID, no username listed.  I seems I have some ghost users on my system.  Not sure whether this is an issue on the domain side or on the server.  I'll try rebooting my DC's again.




On Thu, Jan 21, 2016 at 10:35 AM, L.P.H. van Belle <belle at bazuin.nl> wrote:

Hai Nico,

Did your stop samba and start samba already.
I have on one old server, also debian wheezy samba 3.6.6 about the same problem, stopping samba and starting solves it.  !! restarting samba not !!
Give it a try.

If that does not work, try the following.
Disconnect all you netwerk shares on the computer and reconnect them.
I have 1 pc here (win7 64bit) which is getting a "ghost" share.
With that i mean one user gets a drivemapping to another users folder,
When this happens, we have also the problem that this user cannot open or write any file.

So 2 thing you can tryout without rebooting the server.



> -----Oorspronkelijk bericht-----
> Van: samba [mailto:samba-bounces at lists.samba.org] Namens Nico De Ranter
> Verzonden: donderdag 21 januari 2016 10:25
> Aan: samba
> Onderwerp: [Samba] Cannot write to home directory, but I can write to
> subfolder

> I have a storage server running samba 3.6.6 on Debian. Unfortunately I
> cannot easily upgrade samba as this is a production server.  The server is
> a member of a Samba-based domain, unix users are still handled by NIS.
> When I logon to a Windows 7 pc (also part of the domain) with my own user
> my homedirectory is automatically available as H:\. I can see the content
> of the directory but when I try to write anything I get "You need
> permission to perform this action".  On unix I have no problem creating
> files in that same folder.  The same goes for any existing subdirectories.
> I created a folder with 777 permissions. When I try to create a folder
> inside that folder from Windows the action succeeds. When I look at the
> new
> folder from unix the user and group are the same as the other folders,
> permissions are set to 755. The only difference is that there is a default
>     default:user::rwx
>     default:group::rwx
>     default:other::r-x
> (which I do not like actually as this means that anything I create from
> unix in that folder now gets default permission 775, ugh).
> Setting that same ACL on my homedirectory doesn't change a thing, I am
> still unable to create any files or folders in my homedirectory.  I am
> however able to create files and folders in the subdirectory I created
> from
> windows.
> Fortunately most other users can create files in their homedirectories
> without problems.
> Any idea what could be causing this and how to resolve it?
> Rebooting the server is not an option.
> Nico





Romeinse straat 12
3001 Leuven – Belgium
T. +32 16 40 12 82
F. +32 16 40 84 77





Nico De Ranter

Operations Engineer

T. +32 16 40 12 82

M. +32 497 91 53 78



Romeinse straat 12
3001 Leuven – Belgium
T. +32 16 40 12 82
F. +32 16 40 84 77




More information about the samba mailing list