[Samba] Desynced DC

Sébastien Le Ray sebastien-samba at orniz.org
Thu Feb 25 13:15:45 UTC 2016

Still the same error…

ERROR(<class 'samba.drs_utils.drsException'>): DsReplicaSync failed - 
drsException: DsReplicaSync failed (-1073610723, 

Would copying the sam.ldb* files from a working DC be a mistake?

Le 25/02/2016 12:45, Achim Gottinger a écrit :
> Yes they are, see samba-tool drs replicate -h.
> Am 24.02.2016 um 16:24 schrieb Achim Gottinger:
>> Have you tried to replicate with the --sync-forced and --full-sync
>> options?
>> Am 24.02.2016 um 14:31 schrieb Sébastien Le Ray:
>>> Hi list,
>>> We use samba 4.1.17 (debian's version) on several DCs. I just
>>> realized that one of them is desynced and cannot get it to resync.
>>> The long story: we got 5 DCs splitted over several sites. Recently
>>> we had to replace one of them (let's call him DC5). Since both had
>>> to run in parallel for data recovery/users work we decided to join a
>>> brand new DC (DC6) and latter demote the second one (DC5). Where
>>> things get even more complicated is that once DC5 has been removed
>>> we put DC6 on its IP (following wiki). We performed some cleanup in
>>> the DNS and all was beautiful, data got replicated. However I just
>>> realized that a completly different DC (say DC3) didn't catch the
>>> replacement. samba-tool drs showrepl reports errors where we can see
>>> the no-more existing DC and a DNS query returns the old DC6 address.
>>> Is there a way to force replication (even by copying files
>>> manually)? samba-tools drs replicate fails miserably without any
>>> meaningful error.
>>> Thanks in advance

More information about the samba mailing list