[Samba] back to group listing 4.1.6 vs 3.6.3

Jeff Sadowski jeff.sadowski at gmail.com
Tue Feb 9 20:00:04 UTC 2016

So I had an older machine loose authentication with power broker. I decided
to join it with samba and winbind. Wala it worked. But it worked better
then my newer machine.

My entire smb.conf

   security = ads
   workgroup = SUBDOMAIN
   idmap config * : backend = tdb
   idmap config * : range = 2000-7999
   idmap config SUBDOMAIN:backend = ad
   idmap config SUBDOMAIN:schema_mode = rfc2307
   idmap config SUBDOMAIN:range = 8000-9999999
   winbind nss info = rfc2307
   winbind use default domain = yes
   winbind nested groups=yes
   winbind expand groups=10
   winbind enum users = yes
   winbind enum groups = yes
   restrict anonymous = 2

Old computer is running Ubuntu 12.04
Samba version 3.6.3

New computer is running Ubuntu 14.04
Samba version 4.1.6

as my user on my old computer id shows all my groups but on my new computer
id only shows about a quarter.

Is there a way to get 4.1.6 to act more like 3.6.3? what config options
might be causing this?

More information about the samba mailing list