[Samba] Previously extended schema not working in 4.4.0

Jonathan Hunter jmhunter1 at gmail.com
Wed Apr 13 22:45:28 UTC 2016

Thanks Rowland.

On 12 April 2016 at 22:39, Rowland penny <rpenny at samba.org> wrote:

> I have now remembered something, not sure if it helps but see here:
> https://lists.samba.org/archive/samba/2014-September/185225.html
I definitely think this is in the same area - the issue I'm having also
seems to be relating to replication - but I'm still not really sure why
samba is suddenly rejecting the new object I am trying to create :(

I have checked CN=schema on all four of my DCs using ldbedit; then saved
the output to a different text file using the editor (I couldn't see an
easy way to extract just this part - but this seems to have worked, at

I checked my custom attributes:
# ldbedit --cross-ncs -s sub -H ./sam.ldb -b
CN=Schema,CN=Configuration,DC=mydomain,DC=org,DC=uk '(name=myattrib*)'
Between all four DCs, I only found differences in the order
attributes/values were returned (e.g. mustContain and mayContain have
multiple values and these appeared in different orders), and uSNChanged and
uSNCreated attributes had different values between DCs. On one DC (only
one) the searchFlags attribute appeared in a different position within the
LDAP entry; it has the same value though, so I can't believe that would
matter at all. Otherwise these all looked completely identical to me, and
all the attributes and types seem to be present.

I also checked what I assume is part of the replication:
# ldbedit --cross-ncs -s sub -H ./sam.ldb -b
Apart from uSNChanged/uSNCreated, and the order some attributes were
returned in, there seem to be some differences in repsFrom:: and repsTo::,
but these are encoded, and using 'diff -u' all I immediately see is that
something is either different, or perhaps the order of values returned is
just different.

I don't feel as though I am all that much closer to finding out why I'm
getting '00202F: replmd_add: error during direct ADD: No rDN found in
replPropertyMetaData' yet - but at least we're eliminating some things, I

I am tempted to find the line of code that produces the error, and see if I
can hack some debugging into it so that it prints out some of the
parameters it's looking for - but I've never delved into the samba codebase
so I don't know how easy or otherwise that might be to add..

"If we knew what it was we were doing, it would not be called research,
would it?"
      - Albert Einstein

More information about the samba mailing list