[Samba] Previously extended schema not working in 4.4.0

Jonathan Hunter jmhunter1 at gmail.com
Thu Apr 14 09:51:26 UTC 2016

One more data point to add..

On 13 April 2016 at 23:45, Jonathan Hunter <jmhunter1 at gmail.com> wrote:

> I have checked CN=schema on all four of my DCs using ldbedit; then saved
> the output to a different text file using the editor (I couldn't see an
> easy way to extract just this part - but this seems to have worked, at
> least)
> I have also checked everything between DC1 and each of the three other
DCs, using ldapcmp - there are no differences found at all.

# samba-tool ldapcmp ldap://dc1 ldap://dc2 schema
--filter=whenChanged,usnChanged,usnCreated ; samba-tool ldapcmp ldap://dc1
ldap://dc2 domain --filter=whenChanged,usnChanged,usnCreated ; samba-tool
ldapcmp ldap://dc1 ldap://dc2 configuration
* Comparing [SCHEMA] context...
* Objects to be compared: 1557
* Result for [SCHEMA]: SUCCESS
* Comparing [DOMAIN] context...
* Objects to be compared: 613
* Result for [DOMAIN]: SUCCESS
* Comparing [CONFIGURATION] context...
* Objects to be compared: 1654

So I am still stumped as to why I now can't create objects :-( But at least
it makes sense that I get the same error across all of my DCs, as they seem
to be consistent if nothing else..

> I don't feel as though I am all that much closer to finding out why I'm
> getting '00202F: replmd_add: error during direct ADD: No rDN found in
> replPropertyMetaData' yet - but at least we're eliminating some things, I
> guess.



"If we knew what it was we were doing, it would not be called research,
would it?"
      - Albert Einstein

More information about the samba mailing list