[Samba] samba4.2.0 crashes on connection attempt with an internal samba error...

Rowland Penny rowlandpenny at googlemail.com
Sun Mar 29 15:23:24 MDT 2015

On 29/03/15 15:48, Horst.venzke at remsnet.de , Horst Venzke ,Remsnet 
Consulting und Internet Services LTD, Niederlassung Deutschland wrote:
> Hello Rowland
>> I tried something very very similar (but in english), it didn't work,
>> what did work (and was a lot easier) was removing systemd.
>> I tried to get systemd to work with samba, I really, really tried, I
>> just couldn't make it work, I tried various things for a couple of hours
>> and couldn't make it work, just 5 mins to remove systemd, and samba now
>> works.
> Do your dbus user session services work ?
> I had some issues from that with cups and samba4 ads  on opensuse 13.1 and up .. did ago bug reports .. +1 year ago  back.
>> I know what I will be doing in future.
> hehe .. yu'll kill systemd ? :-)
> ... and blame its developers ?
>> Rowland
> regards

OK, not really one to give up, I installed jessie in another VM and 
compiled samba 4.2 again and then tried to get samba & systemd to work 
together. I finally got systemd to start the samba daemons, OK what 
idiot decided that the program PIDs *MUST* go in /run ???? even though 
samba hardcodes them to go into /usr/local/samba/var/run.


More information about the samba mailing list