[Samba] Fwd: Samba4 + external ldap

Rowland Penny rowlandpenny at googlemail.com
Tue Mar 24 12:48:38 MDT 2015

On 24/03/15 18:40, Elias Pereira wrote:
> I had tried with the "root", but also gave error: *Could not find the
> username.*
> The first time this happened I ran the following command:
> root at sol:~# smbpasswd -a root
> smbldap_search_domain_info: Searching
> for:[(&(objectClass=sambaDomain)(sambaDomainName=POA))]
> smbldap_open_connection: connection opened
> ldap_connect_system: successful connection to the LDAP server
> New SMB password:
> Retype new SMB password:
> init_sam_from_ldap: Entry found for user: root
> Forcing Primary Group to 'Domain Users' for root
> init_ldap_from_sam: Setting entry for user: root
> ldapsam_modify_entry: LDAP Password changed for user root
> ldapsam_update_sam_account: successfully modified uid = root in the LDAP
> database
> On Tue, Mar 24, 2015 at 3:10 PM, Rowland Penny <rowlandpenny at googlemail.com>
> wrote:
>> On 24/03/15 17:32, Elias Pereira wrote:
>>> it has been sometime since I used an NT-4 style domain, but I seem to
>>>> remember that you need to run the command as root and the user needs to
>>>> exists as a Unix user.
>>>>   You were right! Fixed!
>>> Continuing:
>>> But now when I try to join a window xp sp3 in the domain, it does the
>>> following error:
>>> *Logon failure: unknown user name or bad password.*
>>> Note: The user I'm putting to enter the domain, belongs to the Domain
>>> Admins.
>>> I run the "tail -f syslog" on openldap server.
>>> See the link: http://pastie.org/private/zk2t5jtwzvujakiifvltea
>> Again, this is from memory, you have to use the user 'root' and the
>> password you set for him.
>> Rowland
>> --
>> To unsubscribe from this list go to the following URL and read the
>> instructions:  https://lists.samba.org/mailman/options/samba

OK, just done a quick search to refresh my memory, have you run this 
command:  smbpasswd -w mysecretpwd

What howto are you following (if any)


More information about the samba mailing list