[Samba] Samba 4.2 as AD DC on Raspberry Pi 2 + Raspbian - some notes, more questions

Matthias Busch catwiesel at gmx.net
Mon Mar 23 07:59:27 MDT 2015


after successfully building* and getting the AD DC working with samba 
4.2** on the raspberry pi b I got the pi 2 and... ran into walls...

*see https://lists.samba.org/archive/samba/2015-March/190073.html
** see https://lists.samba.org/archive/samba/2015-March/190057.html

Since the setup in the ** link worked so well, I followed the same 
procedures during the 4.2 setup with the pi 2

However, strange stuff happened:

- I got errors during make. never in the same place twice (I did not log 
those, sorry!), nothing google could help with
- Sometimes, starting make after a failure would finnish without errors
- I could get it to build and make install
- (trying to build with man pages still doesnt work, very reproduceable)

- when trying to chmod 755 the startscript I once got a segfault. chmod 
without parameters produced the segfault as well, gone after reboot - 
very strange

after "succesfully" building and setting samba up, it
- sometimes would refuse to start
- started to show the same dns problems as described in my first post, 
kinit administrator at MY-DOMAIN.HOME threw errors
in general, it was just wonky, I did not stop to write everything down 
and look around but started new...

today I succesfully configures, built and installed samba without errors.
- did not overclock the system (maybe the +100MHz were too much for my 
pi 2 - with passive cooling. did not expect that but could be)
- removed cups-common before configure (might have done that on the 
previous working pi b tests and forgot to write it down)

-------> would someone with a pi 2 and some time try to build samba 4.2 
on his, maybe 2-3 times and report back if he had any problems? expect 
configure to take 6.5min, make to take ~1.5hrs and make install to take 
see ** for steps

Everything looks ok so far, I am still testing a bit to see if something 
is not operating as expected.

A few question have surfaced, probably unrelated to the pi 2

- samba internaldns: dynamic updates / reverse dns
I added a reverse dns zone. it is not dynamically updated. is this 
possible with samba internal dns? if so, how? do I need to lower dns 
security? would it be feaseable to dynamically update internal dns with 
a a dhcp server running on the pi 2?

- user shares:
probably unrelated to samba and related to me being to stupid to setup a 
user share correctly...

I created two shares /srv/samba/public and /srv/samba/user
via win7 "rsat" I connected to samba and can see/edit the shares (set ACLs).

-- public is both share/security domain users can read/write (and the 
other usual stuff like owner, administrator...). works

-- user:
----share: domain users can read
----security: domain users can see, list files (only this folder!!!)

now, creating a new user, setting it up that H: is mapped to 
\\samba\user\%username% - it creates the folder in the user share, adds 
the user as full access. and the domain users read only is not inherited.

still, the user can not write to his username share?! What is confusing 
me, with the pi b I set it up as well, and it worked without any hassle...
any ideas?

well,thanks for listening me ramble on.

More information about the samba mailing list