[Samba] Migration Samba3 -> Samba4: Accessing domain member server is not working

Roland Schwingel roland.schwingel at onevision.com
Thu Jul 9 11:50:34 UTC 2015

Hi Rowland

 > Tried various things, including setting up bind9 DNS server on the PDC,
 > nothing until I sat and had a thought 'does samba know the user', quick
 > check with pdbedit proved it didn't DOH, so 'smbpasswd -a root' ,
 > entered the passwd twice and tried again, it now worked, don't know if
 > this is your problem.

Thanks for your time testing and investigating all this!

But this appears not to be the problem I had. I tried you approach and 
resetted my samba on my testmachine from bloody scratch. Joining to my 
PDC was not the problem - as before. Problem was accessing a share on my 
testmachine from windows. This still only works if I fire up winbindd 
after I have joined the domain. I did *NO* winbindd config things. 
Neither in smb.conf nor nsswitch.conf/pam. I appears that winbindd just 
needs to be there to create the magic. Doing the 'smbpasswd -a root' did 
not change anything - here for me and my desert.

Thanks again for your help ...


More information about the samba mailing list