[Samba] samba4 and terminalserver licensing

Martin Feldbacher martin.feldbacher at stegbauer.info
Wed Feb 4 03:43:38 MST 2015


I'm using three Windows Server 2012R1 (1x Terminalserver-License-Server+Citrix Studio, 2x Terminalserver-Sessionhosts+Citrix VDA) and a debian Server with samba4 running on. 
I used the following How-To: 

But the two Terminalserver-Sessionhosts are not using the Terminalserver-License-Server for licensing and I don't know why. 
I already acitvated the RDP-CALs on the License-Server, and set the correct GPO entries to tell the Terminalserver-Sessionhosts to use the License-Server for licensing (I've tried hostname, ip, fqdn), and I already put the Terminalserver-Sessionhosts zu the local group "RDS-Endpointserver". The GPO settings are assumed (checked registry on the terminalservers). 

The following roles and features are installed on my windows servers: 
terminalserver-license-server: Remotedesktop-licensing, Remotedesktop-Sessionhost, IIS, RSAT-Tools 
terminalserver1: Remotedestkop-Sessionhost, RSAT-Tools 
terminalserver2: Remotedestkop-Sessionhost, RSAT-Tools 

I've also tried to delete the test-license registry-key as written in the How-To, but nothing changed. 
All three Windows Servers are members of the samba4 domain. 

Does anybody has an similar setup working ? Need help 

BR, martin 

More information about the samba mailing list