[Samba] Resetting default permissions on share

James lingpanda101 at gmail.com
Mon Aug 24 16:56:57 UTC 2015

On 8/24/2015 12:43 PM, Sébastien Le Ray wrote:
> Hi
> setfacl -Rb /srv/samba/share
> chown nobodycares:a group with SeDiskOperatorPriviledge /srv/samba/share
> chmod g+rwx /srv/samba/share
> always did the trick for me
> Regards
> Le 24/08/2015 18:35, James a écrit :
>> Hello,
>>      How do I reset default folder permissions? For instance I have the
>> following in my smb.conf
>> [share]
>>      path = /srv/samba/share
>>      read only = no
>> Now lets say I have modified ACL's and I just need to start clean as if
>> I just created the folder for the first time(mkdir -p /srv/samba/share).
>> I have tried the following without luck.
>> setfacl -b /srv/samba/share
>> chown root:root /srv/samba/share
>> chmod 755 /srv/samba/share
>> Every time I go back to the share tab using Windows Computer Management
>> I see my previous entries. I would expect to see the default 'Everyone'
>> group. The security tab is missing the 'CREATE OWNER' and 'CREATE GROUP'
>> as well. Not to mention the "Include inheritable permissions from this
>> object's parent" is un-ticked from a prior modification. It should
>> default on. With that said. How does one start over on a share when
>> things don't go as planned? Using Debian Wheezy and Samba 4.1.17 member
>> server. Thanks.

Unfortunately it doesn't seem to work. I even tried 'net cache flush'
and 'smbcontrol all reload-config' after the commands. Getfacl appears
to show correct permissions.

# file: srv/samba/share
# owner: root
# group: root

ls -l looks correct

drwxr-xr-x 2 root root 4096 Aug 24 11:55 share.


More information about the samba mailing list