[Samba] samba 4.2 RDP problem (solved)

Andrew Bartlett abartlet at samba.org
Mon Apr 27 00:37:03 MDT 2015

On Wed, 2015-04-22 at 17:12 +0200, L.P.H. van Belle wrote:
> sorry for the noise.. 
> I missed the solution in my mail. just saw it online.. 
> The working version for rdp login.. 
> I can confirm also that after adding these to the smb.conf 
> dcerpc endpoint servers = epmapper, wkssvc, rpcecho, samr, netlogon, lsarpc, spoolss, drsuapi, dssetup, unixinfo, browser, eventlog6, backupkey, dnsserver, remote, winreg, srvsvc
> auth methods = sam, winbind, ntdomain, ntdomain:winbind
> I was able to login with RDP also. 
> sernet samba 4.2.1 - Windows 7 64bit. 

To be VERY clear, neither of these things are solutions.  They are
debugging aids, but running in either of these configurations in the
long term (I say this because in Samba, suggestions like this turn up in
google for years) will just result in pain. 

'smb' means the NTVFS file server, and while quite capable, and still
tested, it hasn't been worked on in years, and has no support for things
like POSIX ACLS, SMB3, VFS modules and unix extensions.

the changes to 'auth methods' makes the server behave in a weird
combination of an NT4 DC and an AD DC.  

That said, I find it most intriguing that these help, and that
information has been recorded on the bug, and will assist those who made
the change between 4.1 and 4.2.

Andrew Bartlett

Andrew Bartlett                       http://samba.org/~abartlet/
Authentication Developer, Samba Team  http://samba.org
Samba Developer, Catalyst IT          http://catalyst.net.nz/services/samba

More information about the samba mailing list