[Samba] wbinfo -u/-g/-n works, but not 'wbinfo -i' or 'id'

Horacio G. de Oro hgdeoro at gmail.com
Sat Apr 18 13:35:15 MDT 2015

On Tue, Apr 14, 2015 at 10:59 AM, Adam Tauno Williams
<awilliam at whitemice.org> wrote:
> I am experiencing much the same issue; wbinfo -u/-g works but getent
> passwd/group only contains a very partial user list and querying a
> specific user causes the WBC_ERR_DOMAIN_NOT_FOUND error.  Although
> otherwise the domain is functional and there are active workstations.
> Did you every identify a solution?

We solved that setting the GID of the AD users (setting the UIDs
didn't solved that... you need to set the GID too). See [1].

Just FYI: another BIG issue we have was modifications of groups requiring too
many time to propagate to fileservers (form minutes to hours). The only
workaround I've found to that issue is [2]. We are using Samba 4.1 now.


[1] https://wiki.samba.org/index.php/Using_RFC2307_on_a_Samba_DC#Using_ADUC_to_set_Unix_Attributes_on_a_user_account
[2] https://lists.samba.org/archive/samba/2014-October/185604.html


Horacio G. de Oro

    Email: hgdeoro at gmail.com
      Web: http://www.data-tsunami.com/english/
      Cel: +54 9 3572 525359
 LinkedIn: https://www.linkedin.com/in/hgdeoro

Linux Sysadmin - Python/Java Web Developer - DevOps - Big Data

More information about the samba mailing list