[Samba] Windows 7 connecting to Samba share issues

Joseph, Matthew (EXP) matthew.joseph at lmco.com
Wed Oct 1 11:02:41 MDT 2014


We are currently upgrading our Windows XP PCs to Windows 7 and I'm running into some weird issues.

Windows XP/7 PCs connect to Active Directory on Windows 2008 R2
Samba 3.5.10-125 is installed on RHEL 6.3 Server. RHEL servers are connected to an FreeIPA (IdM) server which uses the Red Hat Password Sync tool to sync passwords.

So we just started testing Windows 7 and so far the first few went great. We had 0 issues with access our Samba shares.
I tried deploying a new PC today and now I can't access the Samba shares (The Windows 7 image has not changed).
Here are the errors that are in the log.workstationname under /var/log/samba

Getpeername failed. Error was Transport endpoint is not connected
Auth/auth_server.c:422(check_smbserver_security) password server #ACTIVE_DIRECTORY_SERVER# rejected the password: NT_STATUS_INVALID_PARAMETER

Now the domain user can log in with no issues on one of the working Windows 7 PCs but once he logs into that PC it spits out those errors on the Samba server.
I've tried re-imaging the PC but it came up with the same error.
The PCs (both working and not working) are all under the same GPO in Active Directory.

Has anyone seen this behavior before?



More information about the samba mailing list