[Samba] Auth fail getpwuid(3000007) failed

Leander S. info at netocean.de
Sat May 17 10:03:57 MDT 2014

" <samba at lists.samba.org>
Content-Transfer-Encoding: quoted-printable
Mime-Version: 1.0 (1.0)

Hi Andrea,

thanks for your reply. Fortunately I was able to solve it. I recompiled samb=
a and everything worked out as expected. Funny but I can't tell why, since t=
he config stayed exactly the very same as before ;)

Switching off winbind also did not help to solve my problem. Issues where st=
ill the very same when I tried this. Since I run a plane so called standalon=
e fileserver, I currently anyway don't have winbind switched on.

One cause of your trouble could alsobe the way of how you initialize thesamb=
a server. Are you using samba-tools? I got told not to use them for aplane f=
ileserver - ONLY for AD / DC purpose.

Is your FreeBSD freshly installed, or isitan older system where you changed s=
omething recently? ... maybe some updates?

Kind Regards

>> Am 17.05.2014 um 17:18 schrieb Andrea Venturoli <ml at netfence.it>:
>> On 05/02/14 10:38, Leander Sch=C3=A4fer wrote:
>> Hi
>> sorry to bother, but all of a sudden after a fresh install of samba with
>> the regular smb4.conf it keeps on failing when users try to authenticate:=

> Hello Leander.
> Sorry to bother you, but I think I'm having the same problem you have (had=
> Did you solve it?
> On a FreeBSD box, Samba suddenly stopped authenticating, or, better does i=
t intermittently (see my thread "Intermittent failure" if you want).
> Stopping Winbindd seems to solve (for unknown reason), but obviously also p=
revents PAM from working...
> bye & Thanks
>   av.

More information about the samba mailing list