[Samba] samba4: DC doesn't start up

Sven Schwedas sven.schwedas at tao.at
Thu May 8 03:47:16 MDT 2014

On 2014-05-08 11:23, Rowland Penny wrote:
> On 08/05/14 10:10, Sven Schwedas wrote:
>> On 2014-05-08 10:52, Rowland Penny wrote:
>>> On 08/05/14 09:35, Sven Schwedas wrote:
>>>> I tried joining a new DC to my AD domain (Samba 4.1.6).
>>>> Join claimed to have worked, but samba refuses to start afterwards:
>>>>> http://pastebin.com/jJiTzxsG
>>>> Apparently it doesn't recognize its role any more? What went wrong?
>>> Hi, everything looks ok, so it should work, perhaps there is something
>>> wrong in your smb.conf ?
>> Yeah, I still had security = ads in my smb.conf (together with server
>> role = active directory domain controller). The name is a bit
>> misleading. :-)
> I take it that you already had an smb.conf prior to joining the domain
> as a DC, in which case, I think that you may have found a bug. If you
> try to provision a new domain and there is already a smb.conf, the
> provision errors out, I would have thought that the same would happen
> when you try to join a DC, as part of the join is writing the smb.conf.

I already had a smb.conf, and the join didn't modify it at all.

> Rowland

Mit freundlichen Grüßen, / Best Regards,
Sven Schwedas
TAO Beratungs- und Management GmbH | Lendplatz 45 | A - 8020 Graz
Mail/XMPP: sven.schwedas at tao.at | +43 (0)680 301 7167

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 665 bytes
Desc: OpenPGP digital signature
URL: <http://lists.samba.org/pipermail/samba/attachments/20140508/73e93470/attachment.pgp>

More information about the samba mailing list