[Samba] samba4: DC doesn't start up

Rowland Penny rowlandpenny at googlemail.com
Thu May 8 03:23:30 MDT 2014

On 08/05/14 10:10, Sven Schwedas wrote:
> On 2014-05-08 10:52, Rowland Penny wrote:
>> On 08/05/14 09:35, Sven Schwedas wrote:
>>> I tried joining a new DC to my AD domain (Samba 4.1.6).
>>> Join claimed to have worked, but samba refuses to start afterwards:
>>>> http://pastebin.com/jJiTzxsG
>>> Apparently it doesn't recognize its role any more? What went wrong?
>> Hi, everything looks ok, so it should work, perhaps there is something
>> wrong in your smb.conf ?
> Yeah, I still had security = ads in my smb.conf (together with server
> role = active directory domain controller). The name is a bit
> misleading. :-)
I take it that you already had an smb.conf prior to joining the domain 
as a DC, in which case, I think that you may have found a bug. If you 
try to provision a new domain and there is already a smb.conf, the 
provision errors out, I would have thought that the same would happen 
when you try to join a DC, as part of the join is writing the smb.conf.


More information about the samba mailing list