[Samba] problems after lowering tombstone...

Achim Gottinger achim at ag-web.biz
Wed Jul 23 13:50:05 MDT 2014

Am 23.07.2014 21:28, schrieb mourik jan heupink - merit:
> Hi Achim, list,
> Interesting, yes, exactly that seems the case. So...hence my advise 
> against brtfs.
> Stefan told me that perhaps we could lower tombstone in 10-day steps, 
> and wait after each step until everything settles down.
This is an good advice! Took around 25 mins to delete 1000 entries here. 
Had 72000 deleted entries here with 180 days so aprx. 60000 are older 
than 30 days. Means 25 hrs.
Looking forward to an bunch of issues and phone calls tomorrow.
> Now I only hope for some good answers for my (just posted) sssd 
> question, and then hopefully some quieter time ahead...
Can't help you with that. I'm on debian wheezy shipped sssd is too old 
tried to backport it was not too difficult but too much work to do it on 
an regular basis.

> Mourik Jan
>> You know the odd thing is i just decreased tomstone lifetime from 180
>> down to 30 days on an setup with windbind issues in hope to get some
>> speed improvements.
>> The samba process is still busy ~90% and if i run samba-toor drs
>> showrepl i get the same error while still having 5GB free on /var.
>> I assume your db corruption was caused by no space on /var (due to brtfs
>> issues).
>> ERROR(runtime): DsReplicaGetInfo of type 0 failed - (-1073610723,
>>    File "/usr/lib/python2.7/dist-packages/samba/netcmd/drs.py", line
>> 116, in drsuapi_ReplicaInfo
>>      (info_type, info) =
>> ctx.drsuapi.DsReplicaGetInfo(ctx.drsuapi_handle, 1, req1)

More information about the samba mailing list