[Samba] Join Windows machines to a Samba3 domain

Rowland Penny rowlandpenny at googlemail.com
Thu Jan 16 11:29:31 MST 2014

On 16/01/14 18:13, Lea Massiot wrote:
> Hello and thank you for your answer.
> /Rowland Penny-5 wrote> So you set up a samba3 PDC and then tried to join a
> windows AD server to it ?/
> No, I didn't. Sorry for not having been clear enough on that point.
> - I had a working Samba3 server on a machine A.
> - I stopped it and apt-get installed a Samba4 PDC on this same machine A.
> - Then I apt-get purged the samba4 package and tried to rerun the Samba3 PDC
> which used to work perfectly before.
> - Then I realized the Samba3 configuration wasn't working anymore.
> /Rowland Penny-5 wrote> It would seem that ALL your clients are now looking
> for an AD server that is no longer there./
> *Yes indeed, this is what it looks like.
> How can I change these Windows clients behaviour?
> How can I reinit them?*
> /Rowland Penny-5 wrote> I think that you are going to have to look into
> upgrading your S3 server to a S4 AD server./
> I would really prefer not to since it looks complicated to me and that I
> can't really afford a Samba4 setup right now unless there is a really simple
> procedure. But as far as I investigated, it's not straightforward to me.
> Given the fact that I'm not specialized in that matters and that I only know
> how to make DHCPD/BIND9 and SAMBA3 work together (which used to be good
> enough for my needs until now), I would need a good
> tutorial/howto/documentation which I haven't found yet (my OS is Debian
> Wheezy).
> Thank you for helping.
> Best regards.
> --
> View this message in context: http://samba.2283325.n4.nabble.com/Join-Windows-machines-to-a-Samba3-domain-tp4659356p4659399.html
> Sent from the Samba - General mailing list archive at Nabble.com.
I think that you may have to invest some time here if you are going to 
use the windows server, I have a feeling that the latest versions of 
windows will not join to a NT-like server (which a S4 PDC is).

I know that this is no help to you now, but you shouldn't have messed 
with your production setup, you should have tried it out in a test 
environment first, in VM's if need be.

To try and help you, more info is needed, your smb.confs etc to start with.


More information about the samba mailing list