[Samba] Strange saving Errors with Office 2007 since i upgradede from 4.1.3 to 4.1.4

Achim Gottinger achim at ag-web.biz
Sat Feb 22 07:19:46 MST 2014

Am 20.02.2014 14:01, schrieb Achim Gottinger:
> Am 20.02.2014 07:08, schrieb Chan Min Wai:
>> On Thu, Feb 20, 2014 at 5:42 AM, Achim Gottinger <achim at ag-web.biz 
>> <mailto:achim at ag-web.biz>> wrote:
>>     Hi,
>>     Upgraded our debian wheezy servers last week from sernet 4.1.3 to
>>     4.1.4. Since then i get some strange behaviour with Office 2007
>>     for users with roaming profiles.
>>     If an User opens an Word document via double click on an file in
>>     an network share (happens on samba 4.1.4 and as well on MS Server
>>     2003/2008/2008 R2) and tries to safe the file he gets an "this
>>     file can not be saved because it is opened in another session"
>>     message.
>>     If the users opens the same file from withing Word it can be saved
>>     without issues.
>>     If an file is located on the local disc the error also does not
>>     occure.
>>     If an local profiles and user account is used the error does also
>>     not occure.
>>     Other Office Versions (tested 2000 and 2010) are not affected.
>>     There have been no windows or other software updates beside the
>>     samba ipgrade from 4.1.3 to 4.1.4. All our workstations with
>>     Office 2007 are affected, tried it with different user profiles.
>>     Same users have no problems with other office versions on other
>>     machines.
>>     I grabed level3 logs of what is happening if i try to save an file
>>     opened from the explorer vs. opened from within office 2007.
>>     Since there is an workaround for that issue i'll wait for 4.1.5
>>     and see if the problem does still occure before i file an bug
>>     report. Just wondering if there have been any parameter default
>>     changes in 4.1.4?
>>     achim~
>>     --     To unsubscribe from this list go to the following URL and 
>> read the
>>     instructions: https://lists.samba.org/mailman/options/samba
>> Hi Achim,
>> You have an Oplock issue.
>> Try to follow this page
>> http://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/locking.html
>> and adjust some oplock setting...
> Hello Chan Min wai,
> Had read that page and tried to disable level2 oplocks and veto 
> oplocks for doc files but had no success. My setup had worked for two 
> month without the need for special oplock settings. One thing i 
> forgott to mention is that i also redirect most windows folders (not 
> Localdata) to the samba server, so all the temporary files office 
> creates reside in the users home directory.
> Seen one oplock break for normal.dotm during file opening but if i try 
> to save the file only temporary files are affected and no oplock 
> warnings occure.
> Looking at the 4.1.5 list of fixes, this bug may affect me 
> https://bugzilla.samba.org/show_bug.cgi?id=10436.
> An more general question, when the defaults for samba parameters 
> changed in the past it was mentioned in the Changelog or Releasenotes. 
> Can it be there where no new parameters or changes introduced lately?
> achim~
Upgraded to 4.1.5 today but the problem persists. Tried to downgrade to 
4.1.3 but no change to the issue. Now I'm unsure how long the problem 
actually existed, can be customers just did not report it in time.

Checked on the client:

Index Service is disbaled.
Oplocks are disabled.HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet 
\Services\LanmanServer\Parameters EnableOplocks=0 (Also tried it with an 
value of 1, just in case)

Tested on the samba server, disable oplocks, l2 oplocks and kernel 
oplocks. Also disabled dead time, socket, reset on zero vc and aio 
settings. Nothing fixed the issue.

This is the smb.conf i usually use since two month.

         workgroup = DOMAIN
         realm = domain.local
         netbios name = server
         server string = Server
         server role = active directory domain controller
         idmap_ldb:use rfc2307 = yes
         dns forwarder =
         template shell = /bin/bash
         log level = 1
         wins support = Yes
         deadtime = 10
         socket options = TCP_NODELAY SO_KEEPALIVE TCP_KEEPIDLE=120 
         ea support = yes
         store dos attributes = yes
         map readonly = no
         map archive = no
         map system = no
         map hidden = no
         strict allocate = yes
         acl allow execute always = yes
         vfs objects = dfs_samba4, acl_xattr, aio_pthread
         aio read size = 1024
         aio write size = 1024
         csc policy = disable
         dsdb:schema update allowed = yes
         reset on zero vc = yes

         path = /var/lib/samba/sysvol
         read only = No

         path = /data/profiles
         read only = no

         read only = No

More information about the samba mailing list