[Samba] Strange saving Errors with Office 2007 since i upgradede from 4.1.3 to 4.1.4

Achim Gottinger achim at ag-web.biz
Thu Feb 20 06:01:29 MST 2014

Am 20.02.2014 07:08, schrieb Chan Min Wai:
> On Thu, Feb 20, 2014 at 5:42 AM, Achim Gottinger <achim at ag-web.biz 
> <mailto:achim at ag-web.biz>> wrote:
>     Hi,
>     Upgraded our debian wheezy servers last week from sernet 4.1.3 to
>     4.1.4. Since then i get some strange behaviour with Office 2007
>     for users with roaming profiles.
>     If an User opens an Word document via double click on an file in
>     an network share (happens on samba 4.1.4 and as well on MS Server
>     2003/2008/2008 R2) and tries to safe the file he gets an "this
>     file can not be saved because it is opened in another session"
>     message.
>     If the users opens the same file from withing Word it can be saved
>     without issues.
>     If an file is located on the local disc the error also does not
>     occure.
>     If an local profiles and user account is used the error does also
>     not occure.
>     Other Office Versions (tested 2000 and 2010) are not affected.
>     There have been no windows or other software updates beside the
>     samba ipgrade from 4.1.3 to 4.1.4. All our workstations with
>     Office 2007 are affected, tried it with different user profiles.
>     Same users have no problems with other office versions on other
>     machines.
>     I grabed level3 logs of what is happening if i try to save an file
>     opened from the explorer vs. opened from within office 2007.
>     Since there is an workaround for that issue i'll wait for 4.1.5
>     and see if the problem does still occure before i file an bug
>     report. Just wondering if there have been any parameter default
>     changes in 4.1.4?
>     achim~
>     -- 
>     To unsubscribe from this list go to the following URL and read the
>     instructions: https://lists.samba.org/mailman/options/samba
> Hi Achim,
> You have an Oplock issue.
> Try to follow this page
> http://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/locking.html
> and adjust some oplock setting...
Hello Chan Min wai,

Had read that page and tried to disable level2 oplocks and veto oplocks 
for doc files but had no success. My setup had worked for two month 
without the need for special oplock settings. One thing i forgott to 
mention is that i also redirect most windows folders (not Localdata) to 
the samba server, so all the temporary files office creates reside in 
the users home directory.
Seen one oplock break for normal.dotm during file opening but if i try 
to save the file only temporary files are affected and no oplock 
warnings occure.
Looking at the 4.1.5 list of fixes, this bug may affect me 

An more general question, when the defaults for samba parameters changed 
in the past it was mentioned in the Changelog or Releasenotes. Can it be 
there where no new parameters or changes introduced lately?


More information about the samba mailing list