[Samba] samba-tool dns query error WERR_INTERNAL_DB_ERROR [SOLVED]

Nikos Mitas nkmitas at gmail.com
Thu Feb 13 11:40:55 MST 2014


problem solved,

there was a problematic dns record that was causing this error.
in samba log i found this entry: "Unable to parse dns record for
using samba-tool dns delete, i was unable to delete the problematic record,
with the message "record not found",
so i deleted the record with ldap browser.

now everything is working as usual
Windows DNS GUI, samba-tool dns query


Nikos Mitas

On Feb 13, 2014 8:31 AM, "Chan Min Wai" <dcmwai at gmail.com> wrote:

> Hi Nikos,
> I'm gentoo with samba 4.1.4 and I don't see this problem.
> Possible a error on the command which was fixed later?
> Are your windows RAT able to see DNS client correctly? (If yes that seem
> to be good)
> Thank You.
> On Thu, Feb 13, 2014 at 4:50 AM, Nikos Mitas <nkmitas at gmail.com> wrote:
>> Hello,
>> i have two samba 4 domain controllers v4.1.0,  with bind_dlz running so
>> far
>> without problems, but now i have some problems with dns.
>> Running
>> samba-tool dns query dc1 samdom.example.com @ ALL
>> returns this error:
>> ERROR(runtime): uncaught exception - (1383, 'WERR_INTERNAL_DB_ERROR') File
>> "/usr/local/samba/lib64/python2.6/site-packages/samba/netcmd/__init__.py",
>> line 175, in _run return self.run(*args, **kwargs) File
>> "/usr/local/samba/lib64/python2.6/site-packages/samba/netcmd/dns.py", line
>> 988, in run None, record_type, select_flags, None, None)
>> Also the windows dns tool when i click on this particular zone, says it is
>> probably corrupted zone.
>> When i run samba-tool dns query on reverse zones and _msdcs, query works
>> fine
>> samba-tool dbcheck gives me no error
>> nslookup for entries in this zone gives me correct results.
>> any help would be greatly appreciated
>> Nikos Mitas
>> --
>> To unsubscribe from this list go to the following URL and read the
>> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list