[Samba] error with Exchange ldap entries during replication

Andrew Bartlett abartlet at samba.org
Tue Feb 4 20:11:32 MST 2014

On Tue, 2014-01-28 at 19:37 +0000, Paul Rogers wrote:
> Hi All
> I'm trying to join and existing Windows domain with Samba4, on Centos 6.5
> Final.  I initially tried with the Centos rpm's but it seems the
> samba-tools didn't exist so I am now using the rpms from SerNet Enterprise
> The current DC is a Windows Small Business Server 2008 that provides file,
> print, DNS, DHCP, AD and MS exchange/Outlook Web access.
> The domain Company.local is a substitute for the real domain name [Company
> name].local
> I have installed the server using the instructions here:
> https://wiki.samba.org/index.php/Samba_AD_DC_HOWTO
> The rpm versions are:
> sernet-samba-libwbclient-devel-4.1.4-7.el6.x86_64
> sernet-samba-ad-4.1.4-7.el6.x86_64
> sernet-samba-client-4.1.4-7.el6.x86_64
> sernet-samba-debuginfo-4.1.4-7.el6.x86_64
> sernet-samba-common-4.1.4-7.el6.x86_64
> sernet-samba-4.1.4-7.el6.x86_64
> sernet-samba-libs-4.1.4-7.el6.x86_64
> sernet-samba-winbind-4.1.4-7.el6.x86_64
> sernet-samba-libsmbclient0-4.1.4-7.el6.x86_64
> sernet-samba-libsmbclient-devel-4.1.4-7.el6.x86_64
> I have then started following the instructions here:
> https://wiki.samba.org/index.php/Samba4/HOWTO/Join_a_domain_as_a_DC
> At the point at which I run the command:
> /usr/bin/samba-tool domain join Company.local DC -Uadministrator
> --realm=company.local
> I receive the error message:
> Failed to apply records: attribute 'msExchOWATranscodingFileTypes': value
> #1 on 'CN=owa (Default Web
> Site),CN=HTTP,CN=Protocols,CN=SRVMUL01,CN=Servers,CN=Exchange
> Administrative Group (FYDIBOHF23SPDLT),CN=Administrative
> Groups,CN=Company,CN=Microsoft
> Exchange,CN=Services,CN=Configuration,DC=Company,DC=local' provided more
> than once: Attribute or value exists
> Failed to commit objects: WERR_GENERAL_FAILURE
> Join failed - cleaning up
> checking sAMAccountName
> Deleted CN=SVRMUL03,OU=Domain Controllers,DC=Company,DC=local
> Deleted CN=NTDS
> Settings,CN=SVRMUL03,CN=Servers,CN=Default-First-Site,CN=Sites,CN=Configuration,DC=Company,DC=local
> Deleted
> CN=SVRMUL03,CN=Servers,CN=Default-First-Site,CN=Sites,CN=Configuration,DC=Company,DC=local
> ERROR(<type 'exceptions.TypeError'>): uncaught exception - Failed to

Thanks.  Can you also give me the schema entry for this attribute?

ldbsearch -H ldap://dc.company.local -Uadministrator --cross-ncs

That will help me confirm what type of attribute this is, so we can work
out why we fail the rule check on this one.  I think it's DN+String,
which we don't see often, but which we have code to handle.  Also, I
don't see any duplicated entries in that list, but do you?


Andrew Bartlett

Andrew Bartlett
Authentication Developer, Samba Team  http://samba.org
Samba Developer, Catalyst IT          http://catalyst.net.nz/services/samba

More information about the samba mailing list