[Samba] replication issues solved by adding GUID names to /etc/hosts

L.P.H. van Belle belle at bazuin.nl
Wed Aug 27 00:22:21 MDT 2014

Hai Mourik Jan, 

host bd6bdc30-c9b2-4fd4-9bdc-4230fec98d59._msdcs.internal.domain.tld
bd6bdc30-c9b2-4fd4-9bdc-4230fec98d59._msdcs.internal.domain.tld is an alias for rtd-dc1.internal.domain.tld.
rtd-dc1.internal.domain.tld has address
root at rtd-dc1:~# ping bd6bdc30-c9b2-4fd4-9bdc-4230fec98d59._msdcs.internal.domain.tld
ping: unknown host bd6bdc30-c9b2-4fd4-9bdc-4230fec98d59._msdcs.internal.domain.tld 

and samba-tool drs showrepl shows 0 errors. 



>-----Oorspronkelijk bericht-----
>Van: heupink at merit.unu.edu 
>[mailto:samba-bounces at lists.samba.org] Namens mourik jan 
>heupink - merit
>Verzonden: dinsdag 26 augustus 2014 22:59
>Aan: Chan Min Wai; Marc Muehlfeld
>CC: samba at lists.samba.org
>Onderwerp: Re: [Samba] replication issues solved by adding 
>GUID names to /etc/hosts
>Well, I can only tell you what I observed.
>Does ping to the GUID name of your DC's work on your install? And for 
>others here? I am on regular fresh installed wheezy x64.
>On 08/26/2014 09:06 PM, Chan Min Wai wrote:
>> Dear Mourik Jan,
>> I would have to say that something was not right on your 
>system library.
>> I'm sorry that I cannot tell you which one.
>> I was having this issue on my gentoo and recently found the 
>problem was
>> with my LDflags..
>> I've to comment the one I normally use and leave it as default..
>> Where other are basically unchanged...
>> And now my DC can replicate between each other without the /etc/hosts
>> modification.
>> Hope this help....
>> On Wed, Aug 27, 2014 at 2:36 AM, Marc Muehlfeld <mmuehlfeld at samba.org
>> <mailto:mmuehlfeld at samba.org>> wrote:
>>     Hello Mourik Jan,
>>     Am 26.08.2014 20:24, schrieb mourik jan heupink - merit:
>>      > We were having replication issues on wheezy with 
>>      >
>>      > Searching the list I found the following post:
>>      > http://marc.info/?l=samba&m=136999742625184&w=2
>>      >
>>      > It says basically that if you are unable to *ping* 
>the GUID names for
>>      > your dc's, you might be experiencing a glibc error, where dns
>>     names with
>>      > an underscore are not properly resolved.
>>      >
>>      > Note: dns is basically correct, 'host' gives all the 
>correct answers,
>>      > samba_dnsupdate on all dc's says: no dns updates are needed.
>>      >
>>      > The fix in the post, is to add GUID names to 
>/etc/hosts which I
>>     did on
>>      > my dc's, and then all of a sudden ping started working like it
>>     should.
>>      > But ALSO replication! Our 'WERR_BADFILE' errors are gone now.
>>      >
>>      > Now, is this not something that should be much more 
>prominent in
>>     the docs?
>>     Thanks for providing this information. I'll try finding 
>out more about
>>     that and add it to the documentation.
>>     Regards,
>>     Marc
>>     --
>>     To unsubscribe from this list go to the following URL 
>and read the
>>     instructions: https://lists.samba.org/mailman/options/samba
>To unsubscribe from this list go to the following URL and read the
>instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list