[Samba] Shares requiring "Everyone" access... [SOLVED]

Ryan Ashley ryana at reachtechfp.com
Tue Aug 19 07:13:07 MDT 2014

Louis is absolutely correct. Apparently Xerox only provides a bloatware 
driver (it isn't bad like HP bloat, but still) and not a normal one for 
their equipment now. They also have the audacity to say that Samba is 
not a "standard" setup but Mac OSX is! Due to this, they urge people to 
buy Windows Server! That is outrageous! I am personally going to go 
install the driver and printer by hand, one at a time, on every system 
at the client location today. I am also going to note this change and 
urge my clients to not buy Xerox in the future due to their change in 
support for Linux/Samba. Heck, even if they say Linux isn't "standard", 
how about UNIX? Oh well, Samba is working correctly and Windows is 
giving me the wrong error. Thank you to everybody who helped.

Now my last question involves those permissions. I am still not clear on 
one thing. If I leave "Everyone" in the permissions list so the share 
works, will a user in no groups at all be able to browse the share? 
Also, can I safely remove the "CREATOR OWNER" and "CREATOR GROUP" 
settings? If not, how do I ensure the owner and group of files for 
directories and files are inherited and not set by the creator?

On 08/19/2014 08:58 AM, Ryan Ashley wrote:
> I am apt to believe this, but we had it working fine. Mind you, I have 
> the official PPD for the 7545 on the server and the server can print 
> in full-color, two-sided all day long without an issue. When assigning 
> the driver to the printer via print management however, it gives an 
> error about property pages. This happens whether I choose the RAW 
> driver or the official driver on the Linux side. It does assign the 
> driver however.
> I may look at deploying the driver manually and running a script to 
> configure the printer. If that's the case, I no longer need a 
> print-server. The thing is, I have clients all over the place with 
> Xerox printers and Linux servers that work fine. One client has a 
> Xerox Fiery (massive production system) that works, as well as a 
> Phaser and a black and white laser multi-function that both work fine. 
> Maybe it is just this one model.
> Does anybody have any ideas as to how I can make this work with Samba 
> since I'd really prefer to use Samba? If I cannot use Samba as a 
> print-server, so be it, but I really like it as such.
> On 08/19/2014 02:42 AM, L.P.H. van Belle wrote:
>> is due to the Xerox printer driver.
>> I spent lots of time to make this work... and now it works..
>> i used a Windows 7 pc as print server.
>> Best regards,
>> Louis

More information about the samba mailing list