[Samba] Samba4 as AD member & local rights problem...

Thomas Besser thomas.besser at kit.edu
Tue Sep 24 06:14:36 MDT 2013

Am 24.09.2013 09:13, schrieb Thomas Besser:
> Hi Marc,
> Am 19.09.2013 21:07, schrieb Marc Muehlfeld:
>> Am 19.09.2013 16:27, schrieb Thomas Besser:
>>> have a samba4 server as AD member (security =ADS). I have no account
>>> with "Domain Admin" rights, only a normal account with delegated
>>> privilege to managing GPO and for domain join.
>>> I can not manage the printserver resp. upload the win drivers. The
>>> smb.conf option 'printer admin' is gone with v4.
>> Have a look at the print server HowTo, I wrote:
>> http://wiki.samba.org/index.php/Samba_as_a_print_server
> The permission problem I got solved.
> Like described here
> (http://geekyprojects.com/ubuntu/getting-windows-printer-drivers-from-cups/)
> I enabled 'root' for short and granted the 'SePrintOperator' right to a
> normal account and switched back to security = ads
> Now the next problem arises:
> I can now upload the win drivers as described in your howto section
> "Uploading printer drivers for Point'n'Print driver installation"
> successfully. I can also see the files in the samba drivers share.
> But I can not associate it with a printer! The dropdown on
> https://wiki.samba.org/index.php/File:Choose_driver.png is empty!
> Any hint what's wrong here? A bug in samba4?
> Running the sernet samba4 debian package (sernet-samba 99:4.0.9-6) on
> debian wheezy.

Over Windows I can't get work the association. but over Linux command 
line this worked:

rpcclient localhost -U Admin -c 'setdriver "printername" "name of 
printer driver"'



More information about the samba mailing list