[Samba] Can't restore from GPFS snapshots, disk_free error

Eric Chris Garrison ecgarris at iu.edu
Thu Oct 17 07:16:37 MDT 2013


We're trying to set up a GPFS system with Samba running on top with CTDB
managing it.

I have snapshots set up to be accessible in every directory as the invisible
directory .snap

The snapshots are in the following format:

/usr/lpp/mmfs/bin/mmcrsnapshot 1MB `TZ=GMT date + at GMT-%Y.%m.%d-%H.%M.%S`

Šand look like this from the UNIX level:


I've set up shares like this:

path = %H/RSFS
        comment = RSFS Home Directories
        browseable = No
        shadow:snapdir = .snap
#        shadow:basedir = %H/RSFS
        shadow:fixinodes = yes

(I commented out basedir, in case it was causing a path issue, the problem
is the same either way, and I don't think basedir is needed if the .snap is
in every directory).

We can right-click and see "restore previous versions" and see all the other
snapshots.  We can "Open" those files and see the contents.

"Copy" fails with "Item Not Found / Could not find this item / This is no
longer located in Z:\sharename (\\hostname.domainname.edu)(Z:)\dirname."

"Restore" gives the same error, but then the current version disappears.

Upon doing a "Copy", we see the following in the logs:

Oct 15 16:34:06 hostname smbd[18355]: [2013/10/15 16:34:06.706603,  0]
Oct 15 16:34:06 hostname smbd[18355]:   disk_free: sys_fsusage() failed.
Error was : No such file or directory

A similar issue comes up in the following forum, but no solution comes up:


One thing I notice is that it'll put the share name in the path, when that
share is already the root level of (Z:) at that point. I tried putting a
symlink in to the share name under the share, in case it was getting an
extra level in there, but that didn't solve the problem, so it's probably
not it.

In summary, it acts like the snapshot version is unreadable for both Restore
and Copy, but can read it fine for Open.

If I do a Copy or Restore for a whole directory tree, it restores all the
directories, but they are all empty of files, and I get an error for each
file that fails to restore.

I'd appreciate any help. It feels like we're really close. Thanks.

Research Storage
Indiana University

More information about the samba mailing list