[Samba] vestigial DNS entries

David Keegel djk-samba at cyber.com.au
Wed Nov 27 01:22:00 MST 2013

If it helps, I found that a samba 4.0.9 server was trying to send dns
updates to the first IP address which appears in /etc/hosts matching the
server's hostname (in that case,

I'd like to configure samba to send dns updates to a different IP 
address, but haven't yet worked out how to do that (its low priority).

On Tue, Nov 26, 2013 at 08:48:07PM -0500, Lee Allen wrote:
>    David's solution worked - I was able to remove that entry from the
>    internal DNS directory.  Since then I have hunted down and purged
>    several others.  I am pretty sure my internal DNS is now clear of
>    references to and/or '[1]samba-ad.allenlan.net' -- both of
>    these were lingering references from the old configuration.
>    But something is still ... somewhere.  Each time I start samba I get
>    this in my log.samba file:
>    /usr/local/samba/sbin/samba_dnsupdate: couldn't get address for
>    '[2]samba-ad.allenlan.net': not found
>    The only reference I can find anywhere on my system is here:
>    /usr/local/samba/private/named.conf.update :
>    /* this file is auto-generated - do not edit */
>    update-policy {
>            grant [3]ALLENLAN.NET ms-self * A AAAA;
>            grant [4]Administrator at ALLENLAN.NET wildcard * A AAAA SRV
>    CNAME;
>            grant SAMBA-AD$@[5]allenlan.net wildcard * A AAAA SRV CNAME;
>            grant AD$@[6]allenlan.net wildcard * A AAAA SRV CNAME;
>    };
>    But, as the comments indicate, this file is generated.  I can delete
>    the samba-ad line but it bounces right back after a restart.
>    Any ideas?

  David Keegel <djk-samba at cyber.com.au>     Cyber IT Solutions Pty. Ltd.   
   http://www.cyber.com.au/~djk/     Linux & Unix Systems Administration 

More information about the samba mailing list