[Samba] S4-Winbind dumping core on password

smk_va smk_va at yahoo.com
Wed Nov 20 16:47:48 MST 2013

To follow up, I've tried with later versions of sernet-samba-4.0, and today with sernet-samba-4.1.1.  The issue persists. 

No problems logging in from windows with gssapi, and using services with credentials from the ticket cahce -- ssh, smbclient -k, etc. work just fine.  Logging in with a password, sudo su, etc. all fail on password exchange between pam and winbind.

Thanks for looking into this,

On Monday, September 23, 2013 2:11 PM, smk_va <smk_va at yahoo.com> wrote:

Thanks for looking into this.

The attached captures the output from valgrind as requested, for two failed attempts to "sudo su" with password from a domain account.  (I tried adding the '-v' option to valgrind to display the "suppressed" errors, but that didn't have the desired effect.)

Let me know if there's more I can add, and I'll do my best to get you the information.


----- Original Message -----
From: Andrew Bartlett <abartlet at samba.org>
To: S Murthy Kambhampaty <smk_va at yahoo.com>
Cc: "samba at lists.samba.org" <samba at lists.samba.org>
Sent: Sunday, September 22, 2013 11:44 AM
Subject: Re: [Samba] S4-Winbind dumping core on password

On Tue, 2013-09-17 at 15:31 -0700, S Murthy Kambhampaty wrote:
> Samba4-winbind (sernet-samba-4.0.9) on RHEL 6.4 dumps core on password authentication for a domain user (su/sudo), and so domain password authentication fails.  The machine is a standalone server in a Windows AD (2008R2) domain.

Are you able to reproduce this with winbindd running under valgrind?

valgrind --trace-children=yes winbindd


Andrew Bartlett                                http://samba.org/~abartlet/
Authentication Developer, Samba Team          http://samba.org 

More information about the samba mailing list