[Samba] Unable to join samba4 to AD as a DC

Michael Brown michael at netdirect.ca
Wed Nov 6 06:06:40 MST 2013

On 13-11-06 03:03 AM, L.P.H. van Belle wrote:
> See my short howto for ubuntu,
> "samba 4, joining a windows 2008R2 domain as DC. ubuntu 12.04 with sernet packages ( small howto ) W.I.P."
Can you provide a link? Googling for that does not return any results 
other than this mailing list post.

I had been working from 
> there it says.
> ..
> The there is a bug in the sernet package , and because of that there is a fail with the join of the domain,
> fix found here: https://attachments.samba.org/attachment.cgi?id=9210
> and as im looking to your error, it looks lot like the error i was having.
Having no idea what error you had, I can't confirm. I can actually join 
the domain find as a member server, but when I try as a DC or RODC I get 
this error.

Here's the output of the domain join with '-d 9':

> can you try that. ( the patch above )
I tried applying, but my code looks nothing like what you have in the 
patch. I'm using mainline, not the sernet packages.
> Since you are using ubuntu, can you try my short howto?
> and report back any suggestion?

While waiting for a reply, I also tried the samba4 (4.0.8) package on 
FreeBSD and got the exact same error. So I'm thinking it's something in 
AD that samba4 just can't handle yet.


Michael Brown               | `One of the main causes of the fall of
Systems Consultant          | the Roman Empire was that, lacking zero,
Net Direct Inc.             | they had no way to indicate successful
?: +1 519 883 1172 x5106    | termination of their C programs.' - Firth

More information about the samba mailing list