[Samba] Unable to join samba4 to AD as a DC

L.P.H. van Belle belle at bazuin.nl
Wed Nov 6 01:03:10 MST 2013

See my short howto for ubuntu, 
"samba 4, joining a windows 2008R2 domain as DC. ubuntu 12.04 with sernet packages ( small howto ) W.I.P."

there it says. 

The there is a bug in the sernet package , and because of that there is a fail with the join of the domain, 
fix found here: https://attachments.samba.org/attachment.cgi?id=9210

and as im looking to your error, it looks lot like the error i was having. 

can you try that. ( the patch above ) 
Since you are using ubuntu, can you try my short howto? 
and report back any suggestion? 

Best regards, 


>-----Oorspronkelijk bericht-----
>Van: michael at netdirect.ca 
>[mailto:samba-bounces at lists.samba.org] Namens Michael Brown
>Verzonden: dinsdag 5 november 2013 22:02
>Aan: samba at lists.samba.org
>Onderwerp: [Samba] Unable to join samba4 to AD as a DC
>I'm trying to get samba4 up and running as a DC in a lab environment.
>I have a freshly installed AD environment (W2012R2 servers, W2008R2 
>functional level) and I'm trying to join samba4 to it as a domain 
>When I try, I get this:
># samba-tool domain join ad.netdirect.ca DC -Uadministrator 
>Finding a writeable DC for domain 'ad.netdirect.ca'
>Found DC AD2.ad.netdirect.ca
>Password for [AD\administrator]:
>workgroup is AD
>realm is ad.netdirect.ca
>checking sAMAccountName
>Adding CN=SAMBA1,OU=Domain Controllers,DC=ad,DC=netdirect,DC=ca
>Adding CN=NTDS 
>Join failed - cleaning up
>checking sAMAccountName
>Deleted CN=SAMBA1,OU=Domain Controllers,DC=ad,DC=netdirect,DC=ca
>ERROR(<type 'exceptions.AttributeError'>): uncaught exception - 
>'drsuapi.DsBindInfoFallBack' object has no attribute 
>   File "/usr/lib/python2.7/dist-packages/samba/netcmd/__init__.py", 
>line 175, in _run
>     return self.run(*args, **kwargs)
>   File 
>"/usr/lib/python2.7/dist-packages/samba/netcmd/domain.py", line 
>552, in run
>     machinepass=machinepass, use_ntvfs=use_ntvfs, 
>   File "/usr/lib/python2.7/dist-packages/samba/join.py", line 
>1104, in 
>     ctx.do_join()
>   File "/usr/lib/python2.7/dist-packages/samba/join.py", line 
>1007, in 
>     ctx.join_add_objects()
>   File "/usr/lib/python2.7/dist-packages/samba/join.py", line 525, in 
>     ctx.join_add_ntdsdsa()
>   File "/usr/lib/python2.7/dist-packages/samba/join.py", line 458, in 
>     ctx.DsAddEntry([rec])
>   File "/usr/lib/python2.7/dist-packages/samba/join.py", line 368, in 
>     ctx.drsuapi_connect()
>   File "/usr/lib/python2.7/dist-packages/samba/join.py", line 347, in 
>     (ctx.drsuapi_handle, ctx.bind_supported_extensions) = 
>   File "/usr/lib/python2.7/dist-packages/samba/drs_utils.py", 
>line 144, 
>in drs_DsBind
>     return (handle, info.info.supported_extensions)
>I notice that Mauricio Alverez had this problem before[1] but nobody 
>I've tried Ubuntu 12.04.03 (which couldn't even *install*), 
>Ubuntu 13.04 
>(4.0.0+dfsg1-1ubuntu1) and Ubuntu 13.10 (4.0.3+dfsg1-0.1ubuntu1).
>Both give the same error.
>I then tried adding the Services for Unix extension (which I 
>don't even 
>*know* if I did correctly*) to AD as a lark, but it didn't 
>change anything.
>So... anyone have ideas what's going wrong here?
>[1]: http://www.spinics.net/lists/samba/msg110409.html
>Michael Brown               | `One of the main causes of the fall of
>Systems Consultant          | the Roman Empire was that, lacking zero,
>Net Direct Inc.             | they had no way to indicate successful
>?: +1 519 883 1172 x5106    | termination of their C programs.' - Firth
>To unsubscribe from this list go to the following URL and read the
>instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list