[Samba] Samba4 - Manage DNS with MMC shows "ghost" Entries

Denis Cardon denis.cardon at tranquil-it-systems.fr
Tue May 21 13:20:33 MDT 2013

Hi Mark,

> We wanted to deploy Samba4 in our existing Samba3 Environment. So far
> everything (migrating the user data etc) went quite well, but after the
> initial domain-deployment we are seeing ghost entries or random data in our
> "DNS" MMC snap-in on our windows client. Every refresh triggers a new view.
> Basically it is the problem/bug outlined here:
> https://bugzilla.samba.org/show_bug.cgi?id=9791
> As you can see from bugzilla, we tried a lot of different versions but the
> odd behavior still stays the same.
> So we had to stop the deployment and have yet to wait for some information
> regarding this issue.
> We'd really like to deploy Samba4, but we need to understand the outlined
> behavior first before we dare to use it in a running production environment.
> Does anyone else has encountered or seen this behavior as well?

There has been some people having the same weird issue (cf. thread 

The thing is quite visually annoying, but it does not seem to have any 
consequences on the proper functionning of the dns server. I've had this 
issue both with internal DNS and bind, and with a few different versions 
of samba4. I haven't tried the fresh 4.0.6 though.

When looking at entries through samba-tool or directly in ldap with 
apache directory studio, everything seems to be fine. It is probably 
some non ms handling of the dnsRecord attribute data that make the weird 
display. If you can bear with the strange display, this shouldn't be a 
show stopper.



> regards
> Mark B. Sander

Denis Cardon
Tranquil IT Systems
Les Espaces Jules Verne, bâtiment A
12 avenue Jules Verne
44230 Saint Sébastien sur Loire
tel : +33 (0)

More information about the samba mailing list