[Samba] Samba4 does't run netlogon scripts and batch files

Ricky Nance ricky.nance at gmail.com
Wed May 1 05:58:00 MDT 2013

So a couple of things come into play here, when moving to AD you need to
either create a Group Policy that will run the logon script, or set the
logon script per individual. Secondly, .bat should be able to run off the
network drive by setting the correct ACL's (I was thinking chmod 755 from
linux worked, but I may be wrong), in windows, right click on the .bat,
then hit the security tab, and add something like everyone, or
authenticated users, and select the correct acl's (play around with it as I
don't remember right off).


On Wed, May 1, 2013 at 5:41 AM, Varda Zklir <v20z at yahoo.com> wrote:

> I've tried to move from Samba 3.6.14 to Samba 4.0.5. Process went smooth,
> Win8Pro clients joined domain successfully.
> But now netlogon startup scripts does not run on clients at signin. Also
> .bat batch files from network shares does not executes (Win8 says do not
> have permissions) without execute bit set.
> This is the right behavior? How to get back previous?
> If I return 3.6.14 version everything is back to normal and works fine.
> Thank You.
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list