[Samba] samba_dnsupdate utility cannot contact KDC realm

Steven Williams theblessedadventhope at gmail.com
Mon Jun 24 14:25:18 MDT 2013

I am in the process of trying to setup a Samba 4.0.6 AD DC on Fedora 18, 
but dnsupdate is not updating the DNS records since I changed the 
addresses that I have assigned to my NICs. At first I thought the 
internal server didn't want to work, so I tried getting things setup 
with Bind (which is working just not with Samba yet). I am wanting to 
replace our Windows Server 2003 with RHEL 7 (or CentOS) when it comes 
out, but I am using Fedora 18 to research that possibility. What can I 
do to get DNS working again? Here is the command that I ran and it's output:

[root at localhost ~]# /usr/local/samba/sbin/samba_dnsupdate --all-names 
IPs: ['', '']
Traceback (most recent call last):
   File "/usr/local/samba/sbin/samba_dnsupdate", line 506, in <module>
   File "/usr/local/samba/sbin/samba_dnsupdate", line 119, in 
     creds.get_named_ccache(lp, ccachename)
RuntimeError: kinit for OM-SERVER5$@OHM.LOCAL failed (Cannot contact any 
KDC for requested realm)

More information about the samba mailing list