[Samba] Problem with AD users and groups

Marcelo Ruriani systemadmin at helpinghandsofgreenup.org
Thu Jun 6 14:47:43 MDT 2013

To all,
I have run into a problem. I am running Samba 4.1.0 pre1-git-94f11e9 and 
I shut down our server to do regular maintenance. Unknown to me at the 
time, a machine was connected. I know, ugh!! Anyway, when I rebooted and 
tried to use the AD users and groups tool, I get an error stating that 
"naming convention cannot be located because the system detected a 
possible attempt to compromise security".

It seems I locked myself out. I have tried these steps: turn off the 
firewall, ntacl sysvol reset, and dis-join from domain.
The ntacl sysvol reset returns errors (which I'll post if necessary) the 
dis-join worked fine but I cannot re-join to the domain because it 
doesn't detect our domain and throws up an error "domain could not be 
contacted" and "DNS name doesn't exist".

I will say before this event everything worked very well. Any 
suggestions? I will supply more info if requested. I have a followup 
question after I see the replies.

System Administrator
Helping Hands of Greenup

More information about the samba mailing list